cannot locate "conf" dir

Zephyr 4 years ago updated by Nguyen 4 years ago 3

related version: release-5.4.3

Found following problems:

1) mycollab-app-community

After following your guild:


It shows some problems

1.1) you don't have com.esofthead.mycollab.jetty.DefaultServerRunner main class anymore.

I used com.mycollab.server.DefaultServerRunner as substituter

1.2) when run the runner, by clicking [setup] button, the page got a popup:

Can not write the settings to the file system. You should check our knowledge base article at http://support.mycollab.com/topic/994098-/ to solve this issue.

Then, I cannot find open the page.

by some debugging, it seems the program cannot locate the "conf" dir.

I would guess, there is some configuration needed before I can customize mycollab

2) mycollab-services-community

cannot pass maven test

3) mycollab-app-community

ant build:

<copy todir="${installer.staging.dir}/logs">
<fileset dir="${basedir}/src/main/logs"/>


cannot fild file

Mycollab gives a good feeling of powerful open source project, could you please help me on how to start run and learn it?

Best regards,

Zephyr Zhang


Thank you for reporting your issues. Let I answer questions separately:

1.1 The name of the server changed, it should be com.mycollab.server.DefaultServerRunner. We have updated the document https://community.mycollab.com/docs/developing-mycollab/setup-mycollab-projects-with-intellij-ide/

1.2 This issue is rare while the MyCollab does not have the write permission to the folder %MYCOLLAB_HOME%/conf. I guess you are running MyCollab on Unix OS while the Windows users catch this issue more difficult. You should provide the write permission for the current running user. We will update the knowledge base location again.

2. We do not have time to write the specific instructions of unit test but if you see the Travis log https://travis-ci.org/MyCollab/mycollab, all the test cases are passed. There are many integration tests against the database besides the unit test, and you need to set up the database for testing. So in any document, we suggest developers skip running the unit tests by using the maven option -Dmaven.test.skip=true

If you really want to run MyCollab tests, you can post another issue and follow the issue. We will try to update the document when we have time.

3. I guess this issue happens on Windows? You should try to checkout the latest source code from Github, it will solve your issue.

Hai Nguyen

Thanks a lot for your quick replies! I will try your suggestions and get back to you.

By the way, I am running on mac OS, will try to checkout the latest code and come back to you if got more questions.

Thanks again.

Glad to hear that. Let get back to me if you have any further issue.