0
Answered

cannot execute startup script in ubuntu 14.04 LTS server

purushoth 5 years ago updated by Nguyen 5 years ago 9
i am trying to install mycollab 5.0.10 in my new ubuntu server 14.04 LTS. i am using default JRE.
Java -v = java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

while executing the startup.sh script i am getting the below error.

Log /home/user/collab/logs/mycollab.out
Using MYCOLLAB_HOME: /home/user/collab
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further detail s.
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/j etty/util/component/LifeCycle$Listener : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14 2)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2615)
at java.lang.Class.getMethod0(Class.java:2856)
at java.lang.Class.getMethod(Class.java:1668)
at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".

can someone guide me as i am a beginner with linux.

regards,
Purushoth
Under review
Hi Purushoth,

This issue is similar than http://support.mycollab.com/topic/798110-redirecting-to-the-wrong-page-after-database-configuration-and-email-configuration-page/ since we eventually made mistake in MyCollab 5.0.10, we use Jetty 9.3 and it requires Java 8. Your linux is using Java 7 or below and it can not run MyCollab. We will release the new MyCollab 5.1.0 in this weekend, and we will close this issue.


Regards,
Hai Nguyen
Hi Nguyen,
Thanks for your response..
Same for me with Oracle jdk 1.8 (64bit):

romano@romano-Vostro-3350:/usr/local/mycollab/bin$ ./startup.sh
/usr/local/mycollab
Log /usr/local/mycollab/logs/mycollab.out
Using MYCOLLAB_HOME: /usr/local/mycollab
Using JAVA_HOME: /usr/local/jdk1.8.0_45
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/jetty/util/component/LifeCycle$Listener : Unsupported major.minor version 52.0


Any idea?

thanks

romano
Hi Romano,
We will release in this weekend the new MyCollab version with the Jetty 9.2 version and see if this issue has gone. I do believe the script still use java 7 somewhere. I will notify you in this thread as well when we have the new version. Have a nice weekend

Best regards,
Hai Nguyen
Thank you,
I confirm that (apart from setting JAVA_HOME) updating alternatives in Ubuntu 14.04 LTS with

update-alternatives --install /usr/bin/java java /usr/local/jdk1.8.0_45/bin/java 100
(change above path)

and setting with

update-alternatives --config java

solves the problem.

Anyway, this workaround is not the best, because I need multiple jdk versions on the same server. So I'll wait your new release :-)

Thank you!

romano
We have released the new MyCollab 5.1.0 version. It should run well with Java 7, and it has many improvements and features. The UI should look better. You can download it at https://community.mycollab.com/download/ , could you please download and check whether the issue is resolved on your side? Thank you.


Have a nice weekend,
Hai Nguyen
hye hainguyen

can you send me steps to install mycollab in ubuntu server..tq

rao